• Guest FORUM patch notes JUNE! Click Here to learn more!

Question Upload Video Beta

Ken of N9000+

Newbie Member
TubeBuddy Pro
When I uploaded my most recent video via YouTube's new Upload Video Beta, YouTube gave me the notification that they encountered error(s) with my video and couldn't save it. However, it was somehow still published and made public. Has anyone else had similar trouble with the beta or any trouble with it at all? I'm probably overthinking or imagining things, but I have a nagging feeling that it did something to my video.
 

Damon

Well-Known Member
TubeBuddy Pro
Yeah, I have had the similar problems mostly with the end screens and cards. I usually get so frustrated, I just quit and move on o the next video. It seems that now they have relegated it back to classic.
 
OP
OP
Ken of N9000+

Ken of N9000+

Newbie Member
TubeBuddy Pro
Yeah, I have had the similar problems mostly with the end screens and cards. I usually get so frustrated, I just quit and move on o the next video. It seems that now they have relegated it back to classic.
I don’t blame you. I pretty much did the same thing. I was almost done after my upload and all that was left was to click done. But YouTube gave me this warning that it couldn’t save my video because of error(s). After a couple of retries of clicking done and getting the same error, I refreshed the page and ultimately found my video was published and public, even though the initial indication told me otherwise. It was a definite “what just happened” moment. Although the video was “published,” I still feel like it’s not out there because usually at least one of my subscribers or viewers comments, likes, etc. But nothing. Regardless, I’ll be moving onto my next video more wary of YouTube.